Validar SAFT PT Versão 1.04

Validador SAFT 1.04

[Atualização 11-03-2018 Novo Endereço para Validar SAFT 1.04 (aplicação de validação local)]

O validador antigo da versão 1.04 deixou de estar disponível na página da Autoridade Tributária no entanto a Autoridade Tributária disponibiliza agora  o validador SAFT da versão 1.04 como um executável à semelhança do que era nas versões anteriores e está disponível para download no link seguinte:

http://info.portaldasfinancas.gov.pt/apps/saft-pt04/validador_v1_04.exe

O Windows vai mostrar uma mensagem a avisar que o Validador é uma aplicação insegura… clicar em Executar!

Para mais informações sobre o SAFT 1.04 e as suas validações a página agora é http://info.portaldasfinancas.gov.pt/pt/apoio_contribuinte/SAFT_PT/Paginas/news-saf-t-pt.aspx

[SAFT 1.04 XSD]

XSD é um ficheiro com regras de validação para validação de ficheiros xml, existem vários validadores na internet que permitem validar um ficheiro xml com as regras presentes num esquema XSD.

http://info.portaldasfinancas.gov.pt/apps/saft-pt04/saftpt1.04_01.xsd


[VERSÃO ANTIGA]

Este é o primeiro mês em que todas as empresas se são obrigadas a enviar a nova versão do SAFT 1.04, que acrescenta algumas informações às já comunicadas nas versões anteriores.

Para garantir que o seu SAFT está correto antes de o submeter no Portal da Autoridade Tributária pode usar o “analisador” fornecido pela AT para validar e detectar erros que o seu ficheiro possa ter!

Para já ainda não está disponível a versão online igual à que foi disponibilizada para as outras versões, terá que usar a versão Offline que está disponível no link http://info.portaldasfinancas.gov.pt/apps/saft-pt04/validador_v1_04.jar  , não estranhe o ficheiro ser “.jar” isto significa que terá que ter o Java para poder correr este Analisador de SAFT! Este é o único validador de Saft oficial, todos os outros validadores são de entidades externas à Autoridade Tributária e como tal não fornecem qualquer garantia.

Antes de executar o ficheiro que fez download em cima certifique-se de que tem o Java instalado no seu computador, para isso basta visitar o site https://www.java.com/pt_BR/ e instalar a última versão.

Para corrigir possíveis erros no SAFT PT convém sempre consultar o produtor do Software no entanto alguns dos erros podem ter a ver com a informação que está no sistema, seja uma ficha de produto mal preenchida ou um clientes com um dado qualquer inválido, geralmente os erros do analisador mostram o campo onde está o erro, se pesquisar o número do campo no manual do SAFT pode encontrar a origem do erro e corrigir sem ter que recorrer a ninguém!! Também pode dar uma vista de olhos no manual para ter noção de toda a informação que é incluída no ficheiro SAFT 1.04.

http://info.portaldasfinancas.gov.pt/NR/rdonlyres/ACD9174B-FA72-4D80-9E99-760745CC14AA/0/Portaria_302_2016.pdf

Já agora um concelho não usem validadores ou analisadores online que não sejam fornecidos pela AT ou pelo produtor do Software que usam, porque não sabem a quem estão a dar acesso à Faturação, Produtos, Preços, Guias de Transporte, etc… da vossa empresa!!